activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Active MQ Message Processing Failed
Date Thu, 09 Jul 2015 04:29:42 GMT
Art, is there a known issue with the cacheEnabled URI option that would
make you expect it to change this behavior?  Or are you suggesting it
simply because it will change what gets written to the wire and so it might
avoid whatever bug might be causing this behavior?  Either is fine
(especially if it works), I'm just curious what it was that made you think
of that as a possible solution.

Tim
On Jul 8, 2015 2:43 PM, "artnaseef" <art@artnaseef.com> wrote:

> I agree on the versions - first match the client and broker version and see
> if that helps.  Running with the latest too is a good idea to make sure
> this
> isn't a bug that was already fixed.
>
> With that said, one workaround that may help here - disable the cache
> feature in the protocol (it helps by reducing the size of messages when the
> same information is sent many times, such as producer ID).
>
> The setting is called "cacheEnabled".  See the following page for more
> information: http://activemq.apache.org/configuring-wire-formats.html
>
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/Active-MQ-Message-Processing-Failed-tp4698776p4698829.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message