activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: unable to reconnect after exception "Channel was inactive for too long"
Date Wed, 15 Jul 2015 03:28:31 GMT
Jeff, does your keystore work fine up until the error happens and then
begin failing (semi-)consistently, or does it fail with this SSL error
right off the bat?

On Tue, Jul 14, 2015 at 7:06 PM, Hadrian Zbarcea <hzbarcea@gmail.com> wrote:

> Jeff,
>
> I would start with figuring out the reason for "PKIX path validation
> failed/signature check failed". It looks like the keystore is not properly
> configured when attempting to reconnect. I'll try to spend some time on
> this tomorrow.
>
> Cheers,
> Hadrian
>
>
>
> On 06/16/2015 03:18 PM, jeffrey wrote:
>
>> In my application, I am running a 5.9 broker locally and the only
>> transport
>> connector is 2-way SSL.
>> One endpoint is java, using ActiveMq 5.9, the other is C++ using
>> ActiveMQCPP
>> 3.8.2
>>
>> After some unspecified time, the CPP application gets an exception that
>> "Channel was inactive for too long."  I attempt to close the consumer(s),
>> producers(s), session(s), connection(s). Then I create a new connection
>> factory and get a connection from it.
>>
>> As soon as I do connection->start(), I get the same exception back again
>> and
>> again, even though this should be an entirely new connection.  I think at
>> the same time the broker constantly logs one of two things:
>>
>> 2015-06-12 12:27:09,565 | ERROR | Could not accept connection from
>> tcp://IPADDRESS:58426: javax.net.ssl.SSLHandshakeException:
>> sun.security.validator.ValidatorException: PKIX path validation failed:
>> java.security.cert.CertPathValidatorException: signature check failed |
>> org.apache.activemq.broker.TransportConnector | ActiveMQ
>> BrokerService[broker] Task-6952
>>
>> or:
>>
>> 2015-06-12 16:45:13,361 | WARN  | Transport Connection to:
>> tcp://IPADDRESS:57964 failed: java.io.EOFException |
>> org.apache.activemq.broker.TransportConnection.Transport | ActiveMQ
>> Transport: ssl:///IPADDRESS:57964
>>
>> I know this is related to inactivity monitor thread, but I do not want to
>> disable it.
>> Is there something obvious that I am doing wrong?
>>
>> Thanks.
>>
>>
>>
>> --
>> View this message in context:
>> http://activemq.2283324.n4.nabble.com/unable-to-reconnect-after-exception-Channel-was-inactive-for-too-long-tp4697843.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message