activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From adrianbro <adrian...@gmail.com>
Subject ACL Question
Date Fri, 10 Jul 2015 09:04:04 GMT
Hi Guys

If I configure apollo.xml to this

<authentication domain="apollo"/>
<user_principal_kind>org.apache.activemq.jaas.UserPrincipal</user_principal_kind>
<acl_principal_kind>org.apache.activemq.jaas.GroupPrincipal</acl_principal_kind>
   
<access_rule allow="users" action="connect destroy receive consume"
principal_kind="*"/>
<access_rule allow="users1" action="connect destroy create send receive
consume" principal_kind="*"/>

All is good users in the user and user1 group can connect etc

But if I do this:

<authentication domain="apollo"/>
<user_principal_kind>org.apache.activemq.jaas.UserPrincipal</user_principal_kind>
<acl_principal_kind>org.apache.activemq.jaas.GroupPrincipal</acl_principal_kind>
   
<access_rule allow="users" action="connect destroy receive consume"
principal_kind="*" kind="topic" id="12345"/>
<access_rule allow="users1" action="connect destroy receive consume"
principal_kind="*" kind="topic" id="hello"/>

The connecting clients get the following a not authorized error and are not
able to connect.
What am I missing or doing wrong any help would be appreciated

Cheers
Adrian



--
View this message in context: http://activemq.2283324.n4.nabble.com/ACL-Question-tp4699005.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message