activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Total consumer count negative
Date Tue, 09 Jun 2015 12:34:04 GMT
Does this happens reliably and quickly for you?  Can you force it to happen
by taking a certain series of actions?
On Jun 8, 2015 11:45 PM, "ALi" <osatien@gmail.com> wrote:

> It is 5.8.0. As it was working ok we didn't want to update it. The new
> version 5.10 had problems with stomp and websocket. We need to test this
> new version to see if it works and if it doesn't have any problems with it.
> And we don't know if it worths the update. But as we are having this
> incident we need to think about it.
> El 09/06/2015 01:33, "Christopher Shannon" <
> christopher.l.shannon@gmail.com>
> escribió:
>
> > The count shouldn't be negative so this might be a bug.  The broker keeps
> > track of the consumer count using a counter and the counter should be
> > incremented on a new subscription and decremented when a subscription is
> > removed.  So if there are no consumers the count should be 0, not
> negative.
> >
> > What version of ActiveMQ are you using?  If it is older than 5.11.1 you
> > could try a newer version to see if that helps.  Would you be able to put
> > together a test case to reproduce this issue?
> >
> > On Mon, Jun 8, 2015 at 4:42 PM, ALi <osatien@gmail.com> wrote:
> >
> > > When can the total consumer count be negative? We are using this metric
> > to
> > > know how many people is connected.
> > >
> > > We are getting this metric from the jmx perhaps a problem with the
> query
> > in
> > > check jmx eval?
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message