activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: MQTTFrame unknown
Date Thu, 18 Jun 2015 16:26:31 GMT
On 06/18/2015 10:58 AM, breakbad wrote:
> I'm attempting to setup a simple NoB using the MQTT connector, and durable
> topics/subscribers using MQTT 3.1.1 clean_session=false. Configuring broker
> A to connect duplex to broker B, I'm seeing the following in the logs
> simultaneously:
>
> Broker A
> INFO | Establishing network connection from
> vm://localhost?async=false&network=true to tcp://x.x.x.x:1883
>
> Broker B
> WARN | Exception occurred processing: 
> MQTTFrame { type: unknown, qos: AT_MOST_ONCE, dup:false }:
> org.apache.activemq.transport.mqtt.MQTTProtocolException: Unknown MQTTFrame
> type: 0
>
> Broker A active.xml:
> <networkConnectors>
>       <networkConnector name="AtoBduplex" duplex="true"
> uri="static:(tcp://x.x.x.x:1883)"/>
> </networkConnectors>
>
>
> I have a client connected to each broker behind a load balancer, both
> subscribed to topic 'test'. Messages are not being relayed. Any idea what is
> sending this 'unknown' frame?
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/MQTTFrame-unknown-tp4697966.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
You cannot create NoB using anything other than the standard OpenWire
based transport connectors. 

-- 
Tim Bish
Sr Software Engineer | RedHat Inc.
tim.bish@redhat.com | www.redhat.com 
twitter: @tabish121
blog: http://timbish.blogspot.com/


Mime
View raw message