activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Broker log full of Failed to register queue messages
Date Mon, 25 May 2015 04:33:25 GMT
Gurunath, are you using NIO like Ishitori is?  Or is that an unrelated red
herring?

Ishitori, did you ever submit a JIRA bug report for this?  If you haven't,
please do, since it sounds like there's a bug here and without a JIRA entry
it's less likely to get investigated/fixed.

I looked at the code (
http://grepcode.com/file/repo1.maven.org/maven2/org.apache.activemq/activemq-all/5.10.0/org/apache/activemq/network/MBeanBridgeDestination.java)
and it looks to me like we're attempting to create a new MBean in both
onInboundMessage() and onOutBoundMessage().  In both cases, we check for
non-existence before doing the work, but the check is on a different map in
each method (inboundDestinationViewMap and outboundDestinationViewMap,
respectively).  So we can only add one entry for inbound messages and one
for outbound ones, but that still seems like it would allow double
registration in the situation where we had both inbound and outbound
messages.  Am I looking at that right?

Tim

On Fri, May 22, 2015 at 12:05 PM, Ishitori <Ishitori@bk.ru> wrote:

> Nope :( It still happens from time to time. Restart of the services helped
> us, so we do it from time to time.
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/Broker-log-full-of-Failed-to-register-queue-messages-tp4685241p4696875.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message