activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From josealvarado <josealvar...@inspiredsystems.com.au>
Subject Re: How to forward a topic using network of brokers
Date Mon, 25 May 2015 01:21:39 GMT
Hi Tim,

Thank you very much for your time and effort helping me.

I tried all three options you suggested. The first one forwards the queues
but not the topics, the second one the same. The third one does forward the
consumer queue, but the problem is that the service that de-queues the
message on broker A does not do it since the message has been forwarded. I
think forwarding the consumer is a good idea but I need to execute the
message on both brokers, and with this approach the message gets forwarded
to broker B but it does not get executed on broker A.

I followed a couple of tutorials from the web and activemq website but still
no luck. I find it very weird that it works with queues but not topics. I
wondered if the virtual topic has something to do with it, so I tried with a
normal topic but it did not work either. I attached the jConsole to both
brokers to see what was going on. They both display the topics (so I
confirmed they existed) and they both display one consumer, But the topic
never gets forwarded. I also checked log files and it does not show any
errors. but the log says that that a network connection between both brokers
have been established.

I really ran out of ideas... but if you have any more suggestions it would
be great


Thanks again



--
View this message in context: http://activemq.2283324.n4.nabble.com/How-to-forward-a-topic-using-network-of-brokers-tp4696688p4696895.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message