activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Green <james.mk.gr...@gmail.com>
Subject Re: Unix init script buggy
Date Tue, 21 Apr 2015 07:57:03 GMT
You may be interested in AMQ-5733 and a github PR that references it.

On 20 April 2015 at 17:49, Kevin Burton <burton@spinn3r.com> wrote:

> yes.  it’s not very buggy/reliable.
>
> What we did was to use activemq in embedded mode and used our own/internal
> daemon infrastructure.
>
> I guess the point is that activemq is WAY easier to embed than say
> something like Cassandra or Elasticsearch.
>
> So if you can easily make your own Java daemons I would recommend going
> down that path.
>
>
>
> On Mon, Apr 20, 2015 at 7:31 AM, James Green <james.mk.green@gmail.com>
> wrote:
>
> > I'm having a hard time getting a Debian package of ActiveMQ to upgrade.
> >
> > It seems that the ActiveMQ init script is told to "stop". JMX is not
> > configured so this fails, falling back to sending a SIGKILL.
> >
> > The trouble is that "kill" only ever returns the result of itself and
> does
> > not guarantee that the process being killed was successfully terminated.
> > Irrespective of this, the ActiveMQ init script always returns "1" to the
> > caller resulting in the package upgrade failing.
> >
> > It's tempting to return the result of the "kill" command but I'm
> concerned
> > it's not the correct solution.
> >
> > Suggestions?
> >
> > Thanks,
> >
> > James
> >
>
>
>
> --
>
> Founder/CEO Spinn3r.com
> Location: *San Francisco, CA*
> blog: http://burtonator.wordpress.com
> … or check out my Google+ profile
> <https://plus.google.com/102718274791889610666/posts>
> <http://spinn3r.com>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message