activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Session is not getting closed
Date Thu, 19 Mar 2015 12:52:30 GMT
Have you tried to reproduce the behavior on a current version of ActiveMQ
(5.11.1, 5.10.2, 5.9.1, etc.)?  5.4.3 is over three years old (and its
base, 5.4.0, is over four years old) and no one's going to make a 5.4.x
patch no matter what bug you find, so you're only going to get someone to
look into this if you can prove the bug wasn't fixed in one of the many
releases since then.
On Mar 19, 2015 4:07 AM, "suganya" <suganya.ela@gmail.com> wrote:

> Broker version : 5.4.3
> Code written for session creation and closing,
>
> ActiveMQConnectionFactory connectionFactory = new
> ActiveMQConnectionFactory("tcp://1.2.3.4:61616");
> connection = connectionFactory.createConnection();
> connection.start();
> Session session = connection.createSession(false,
> Session.CLIENT_ACKNOWLEDGE);
>
> //while closing a session, will perform a null check and call close().
> session.close();
>
> Also please note that, this application is multi-tenant which has
> individual
> consumer for each customer.
> Though, the messages in queue are read by all the consumers of the queue
> only the intended consumer will acknowledge the message.
>
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/Session-is-not-getting-closed-tp4693402p4693450.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message