activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hadrian Zbarcea <hzbar...@gmail.com>
Subject Re: "Invalid TLS Padding data Error" while trying to connect ActiveMQ via SSL
Date Tue, 31 Mar 2015 13:13:39 GMT
Can you please add a few details about the environment (like the OS type 
and version).

Thanks,
Hadrian


On 03/31/2015 08:48 AM, Tim Bain wrote:
> Based on a few minutes of Googling, the most common cause of that exception
> seems to be code that doesn't read enough bytes before trying to unwrap
> (decrypt) the content.  If that's what's going on, the log lines you posted
> clearly indicate that the bug is in ActiveMQ code rather than code you
> wrote (since it's during the process of interpreting the message's type),
> so I'd recommend you submit a bug in JIRA.
>
> Include the simplest configuration that can reproduce the problem, so that
> whichever developer takes it on is able to recreate the problem, and if
> you're getting any stack traces in your logs, include them in the JIRA bug
> as well.
> On Mar 30, 2015 9:34 PM, "harikrish07121991" <harikrish07121991@gmail.com>
> wrote:
>
>> Hi,
>> I am trying to enable SSL in ActiveMQ broker with the following connector
>> config in activemq.xml
>>          <transportConnectors>
>>
>>              <transportConnector name="openwire"
>> uri="tcp://
>> 0.0.0.0:1883?maximumConnections=1000&amp;wireFormat.maxFrameSize=104857600
>> "/>
>>              <transportConnector name="ssl" uri="ssl://0.0.0.0:8883"/>
>>          </transportConnectors>
>> *But each time when the client tries to connect via port 8883 with client
>> certificates , an error similar to the one below occurs :
>> *
>>
>> 2015-03-30 19:00:58,844 | WARN  | Transport Connection to:
>> tcp://10.30.9.254:45849 failed: java.io.IOException: Unknown data type:
>> 77 |
>> org.apache.activemq.broker.TransportConnection.Transport | ActiveMQ
>> Transport: ssl:///10.30.9.254:45849
>> 2015-03-30 19:00:58,926 | WARN  | Transport Connection to:
>> tcp://10.30.9.254:45850 failed: javax.net.ssl.SSLHandshakeException:
>> Invalid
>> TLS padding data | org.apache.activemq.broker.TransportConnection.Transport
>> | ActiveMQ Transport: ssl:///10.30.9.254:45850
>>
>> Am pretty much sure that the certificates are well formed.Also am using
>> apache-activemq-5.11.0 and openssl version 1.0.1.
>>
>> Kindly help me with the issue am facing .
>>
>> Thanks
>>
>>
>>
>> --
>> View this message in context:
>> http://activemq.2283324.n4.nabble.com/Invalid-TLS-Padding-data-Error-while-trying-to-connect-ActiveMQ-via-SSL-tp4694099.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>

Mime
View raw message