activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From stsc <...@emtnordic.com>
Subject REST API authentication problems
Date Tue, 03 Mar 2015 09:50:26 GMT
Hi I'm using Apache Active MQ 5.11.1 / Java 1.8.0 u31

I can't get the authentication on the REST API to work with anything else
than admin:admin. 4 small tests illustrates the problem.

Test 1: (add message to topic with admin user, default password)

Active MQ out of the box:
Run:
curl -u *admin:admin* -d "body=message"
http://localhost:8161/api/message/STOCKS/JAVA?type=topic

Result (as expected):
topic STOCKS.JAVA created, with 1 message pending

Test 2:  (add message to topic with admin user, wrong password)

Same setup as test 1
Run:
curl -u *admin:adminx* -d "body=message"
http://localhost:8161/api/message/STOCKS/JAVA?type=topic

Result (as expected):
Http error 401 

Test 3:  (add message to topic with admin user, changed password)

Change password in conf/user.properties: admin=adminx
Run:
curl -u *admin:adminx* -d "body=message"
http://localhost:8161/api/message/STOCKS/JAVA?type=topic

Result (not as expected):
Http error 401 

Test 4:  (add message to topic with admin user, default password)
Same setup as test 3
Run:
curl -u *admin:admin* -d "body=message"
http://localhost:8161/api/message/STOCKS/JAVA?type=topic

Result (as expected - but why when test 3 fails...):
Http error 401

Any ideas? 




--
View this message in context: http://activemq.2283324.n4.nabble.com/REST-API-authentication-problems-tp4692334.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message