activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mattjohnson <matt.john...@objective.com>
Subject RE: jdk7 required for 5.11.0?
Date Sun, 08 Feb 2015 22:53:25 GMT
Thanks gtully, appreciate the confirmation.

From: gtully [via ActiveMQ] [mailto:ml-node+s2283324n4691155h98@n4.nabble.com]
Sent: Friday, 6 February 2015 10:05 PM
To: Matt Johnson
Subject: Re: jdk7 required for 5.11.0?

jdk 1.7 is required for 5.11.0

This is explicit in the pom [1] but needs to be spelt out in the doc
and release note. Let me improve that.

[1] https://github.com/apache/activemq/blob/trunk/pom.xml#L143




On 6 February 2015 at 04:18, mattjohnson <[hidden email]</user/SendEmail.jtp?type=node&node=4691155&i=0>>
wrote:

> Hi Folks,
>
> We get "Unsupported major.minor version 51.0" when starting up. Could you
> please confirm this is a requirement for deploying 5.11.0, and not just a
> mistake (on our part, or the packager)? We've been using jdk1.6 to deploy,
> right up to AMQ 5.10.1.
>
> There's nothing in the release notes, nothing I can find in JIRA or on this
> list. In fact, http://activemq.apache.org/getting-started.html explicitly
> states...
>
> "Java Developer Kit (JDK) 1.4.x or greater for deployment and 1.5.x (Java 5)
> for compiling/building. As of AMQ 5.5.0 you need JDK 1.6.0 to build."
>
> ... but then there is  a conversation
> <http://activemq.2283324.n4.nabble.com/JDK-requirements-for-5-11-td4682996.html>
> about requiring jdk7  on the dev list
> <http://activemq.2283324.n4.nabble.com/JDK-requirements-for-5-11-td4682996.html>
> , but it's not clear whether this was just for building, as it seemed to be
> driven by a conflict in Eclipse.
>
> This isn't a showstopper for us, but it will mean extra work for (and
> discussions with) our deployment team.
>
> many thanks,
>
>
> Matt
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/jdk7-required-for-5-11-0-tp4691140.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.

________________________________
If you reply to this email, your message will be added to the discussion below:
http://activemq.2283324.n4.nabble.com/jdk7-required-for-5-11-0-tp4691140p4691155.html
To unsubscribe from jdk7 required for 5.11.0?, click here<http://activemq.2283324.n4.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=4691140&code=bWF0dC5qb2huc29uQG9iamVjdGl2ZS5jb218NDY5MTE0MHwtMjAyODEzMTkwMQ==>.
NAML<http://activemq.2283324.n4.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>




--
View this message in context: http://activemq.2283324.n4.nabble.com/jdk7-required-for-5-11-0-tp4691140p4691224.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message