activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: STOMP+SSL bridge between two ActiveMQ Brokers
Date Fri, 27 Feb 2015 19:17:01 GMT
Nice work debugging that.  It seems like this would be worth documenting on
the ActiveMQ wiki (http://camel.apache.org/stomp.html presumably, though
maybe there's somewhere better), so it's more accessible than the mailing
list archives for the next person...

On Fri, Feb 27, 2015 at 9:33 AM, ttom <tamasb@nikhef.nl> wrote:

> Hi,
>
> Ok, so I managed to get down to the bottom of it, and I'll just post this
> for future reference.
>
> I found out that the StompComponent works just fine when there is not
> requirement for SSL. So I went on to see if SSL is supported by it by
> changing the potocol in the url from 'tcp' to 'ssl'. I was happy to see
> that
> in the logs it actually tries to connect with the SSLEngine but it still
> fails. After a little bit of digging I found out that the StompComponent is
> not passing the SSLContext set in Camel to the stompjms-client, therefore
> the stompjms-client uses the default SSLContext which is not configured
> with
> the right truststore. I added these two options to the activemq startup
> script, and evrything worked fine afterwards:
>
>  -Djavax.net.ssl.trustStore=as-install/domains/domain1/config/cacerts.jks
>  -Djavax.net.ssl.trustStorePassword=changeit
>
> Tom
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/STOMP-SSL-bridge-between-two-ActiveMQ-Brokers-tp4692106p4692166.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message