activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Consumer queues of virtual topic and the web console
Date Tue, 27 Jan 2015 14:09:05 GMT
OK, so I finally got around to looking at your producer and consumer code
in BitBucket.  So it looks like you're intentionally only consuming half
the messages you produce; is that right?  If so, to what end?  You never
mentioned this particular characteristic of your test; any reason you
didn't?
On Jan 27, 2015 7:01 AM, "Tim Bain" <tbain@alumni.duke.edu> wrote:

> Since it sounds like you were able to create a simple setup to cause the
> issue,  can you package it up, create a JIRA bug, and attach your test
> scenario to the JIRA?  That way someone can step through it with a debugger
> and figure out what's going on.
> On Jan 23, 2015 10:40 AM, "krishy" <calvinkrishy@gmail.com> wrote:
>
>> I made the virtual topic selectorAware and the problem went away. All
>> messages are received by the consumer without much delays.
>>
>> I was able to reproduce this only with queues as well. That is the
>> messages
>> were sent to and consumed from a queue based on a selector. After a while
>> the consumer seemed to stop receiving messages. I
>>
>> Though my problem is solved, I am curious what is controlling this
>> behaviour. Why don't messages turn up from the queue after a while?
>>
>>
>>
>>
>>
>> --
>> View this message in context:
>> http://activemq.2283324.n4.nabble.com/Consumer-queues-of-virtual-topic-and-the-web-console-tp4689995p4690349.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message