activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kinamor <romankharkov...@yahoo.com>
Subject Re: Re: How to ensure LevelDB store uses a JNI driver
Date Tue, 27 Jan 2015 00:58:59 GMT
I am having trouble forcing ActiveMQ 5.10.1 on CentOS 6 64bit with Oracle JDK
8 to use JNI driver for LevelDB. 

I did install LevelDB rpm on my OS, but the log file keeps saying it uses
the pure java driver. The Apache docs does not explain on how to use the
JNI. I spent about an hour searching around on many different forums and
there is no solution. Any suggestions?

When I set indexFactory="org.fusesource.leveldbjni.JniDBFactory" - my broker
fails to start. When I omit it, it does start, but it uses Pure Java driver
and it performs slower than KahaDB in 80 concurrent user test.



--
View this message in context: http://activemq.2283324.n4.nabble.com/How-to-ensure-LevelDB-store-uses-a-JNI-driver-tp4664418p4690435.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message