activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sid <hiremat...@gmail.com>
Subject ProducerFlowControl on production - using only one queue - no cluster configured
Date Thu, 18 Dec 2014 09:17:29 GMT
Hi there, 

Following is my activemq.xml, configuration on production, please let me
know if this is good enough to handle production load. Additional
information is that we are not using cluster environment, hence one node is
running the service. And it's only one queque being used for our purpose. 

        <destinationPolicy>
            <policyMap>
              <policyEntries>
                <policyEntry topic=">" producerFlowControl="true"> 
                  <pendingMessageLimitStrategy>
                    <constantPendingMessageLimitStrategy limit="1000"/>
                  </pendingMessageLimitStrategy>
                </policyEntry>
                <policyEntry queue=">" producerFlowControl="true"
memoryLimit="1mb"> 
                </policyEntry>
              </policyEntries>
            </policyMap>
        </destinationPolicy>

----------------------------------------------------------------------------------- 

                <memoryUsage>
                    <memoryUsage percentOfJvmHeap="70" />
                </memoryUsage>
                <storeUsage>
                    <storeUsage limit="1024 mb"/>
                </storeUsage>
                <tempUsage>
                    <tempUsage limit="1024 mb"/>
                </tempUsage>

Thanks,
Sid



--
View this message in context: http://activemq.2283324.n4.nabble.com/ProducerFlowControl-on-production-using-only-one-queue-no-cluster-configured-tp4689071.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message