activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pankajtakawale <pankaj.takaw...@gmail.com>
Subject Replicated LevelDB cluster: failed to page in queue messages
Date Mon, 01 Dec 2014 23:16:53 GMT
Hi,

I faced following exception while testing ActiveMQ leveldb cluster.
On this exception, master demotes itself to slave. New master faces same
exception, and it keeps on happening. Master keeps on rotating without
processing messages. 
Client was not able to send/receive messages.

I've opened jira issue: https://issues.apache.org/jira/browse/AMQ-5459

Any idea what could cause this - leveldb corrupted?
Is there any way to recover out of this without loosing existing messages in
queues? 
I would highly appreciate any pointers to fix this.

Restarting activemq on all cluster nodes did not help, it ran into same
issue. 



Nov 25 15:03:35.777 [esta] Scheduler] - ERROR AbstractStoreCursor - cbtesta
-
org.apache.activemq.broker.region.cursors.QueueStorePrefetch@72e4521c:testpt,batchResetNeeded=false,storeHasMessages=true,size=2516,cacheEnabled=false,maxBatchSize:200,hasSpace:true
- Failed to fill batch
Nov 25 15:03:35.777 [esta] Scheduler] - ERROR AbstractStoreCursor - cbtesta
-
org.apache.activemq.broker.region.cursors.QueueStorePrefetch@72e4521c:testpt,batchResetNeeded=false,storeHasMessages=true,size=2516,cacheEnabled=false,maxBatchSize:200,hasSpace:true
- Failed to fill batch






--
View this message in context: http://activemq.2283324.n4.nabble.com/Replicated-LevelDB-cluster-failed-to-page-in-queue-messages-tp4688222.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message