activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alistair Young <alistair.yo...@uhi.ac.uk>
Subject Re: Camel error in activemq 5.10.0
Date Thu, 23 Oct 2014 22:01:55 GMT
turned out a 3rd party jar in the lib directory was still compiled against
5.8.0. Compiling it against 5.10.0 solved the problem.

Thanks,

Alistair

-----------------
mov eax,1
mov ebx,0
int 80




On 23/10/2014 22:20, "artnaseef" <art@artnaseef.com> wrote:

>Did the jetty.xml file get copied as-is from the older version of
>ActiveMQ? 
>It looks like the exception is complaining that jetty.xml is specifying
>the
>use of a method that doesn't exist.
>
>Here's the method error:
>
> NoSuchMethodError:
>org.osgi.framework.FrameworkUtil.getBundle(Ljava/lang/Class;)Lorg/osgi/fra
>mework/Bundle;
>
>That method translates to the following signature in the
>"org.osgi.framework.FrameworkUtil" class:
>
>    org.osgi.framework.Bundle getBundle(Class clazz)
>
>Most likely the version of that class changed and that method signature
>doesn't exist in the new version.
>
>
>
>--
>View this message in context:
>http://activemq.2283324.n4.nabble.com/Camel-error-in-activemq-5-10-0-tp468
>6668p4686674.html
>Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message