activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Green <james.mk.gr...@gmail.com>
Subject Re: 5.10.0: Unable to connect via jmx
Date Fri, 26 Sep 2014 16:13:19 GMT
public hostname, checked that.

On 26 September 2014 17:08, Tim Bain <tbain@alumni.duke.edu> wrote:

> Was your connection via Jmxterm using the hostname, or localhost?
>
> Is that machine able to do a DNS resolve of its own hostname?  And can you
> try specifying the IP instead of the hostname in the config and in the
> connection info from JConsole?
>
> On Fri, Sep 26, 2014 at 9:46 AM, James Green <james.mk.green@gmail.com>
> wrote:
>
> > I can connect using Jmxterm on the local host itself but not using
> > jvisualvm from another host within the firewalled network. Very odd.
> >
> > On 26 September 2014 15:38, James Green <james.mk.green@gmail.com>
> wrote:
> >
> > > None of those are set here.
> > >
> > > On 26 September 2014 15:31, Geurt Schimmel <
> GSchimmel@schubergphilis.com
> > >
> > > wrote:
> > >
> > >> Hi,
> > >>
> > >> We do this in the startup-script (e.g. /opt/activemq/bin/activemq),
> not
> > >> in activemq.xml:
> > >>
> > >> ACTIVEMQ_SUNJMX_START="-Dcom.sun.management.jmxremote.port=11099 "
> > >> ACTIVEMQ_SUNJMX_START="$ACTIVEMQ_SUNJMX_START
> > >>
> >
> -Dcom.sun.management.jmxremote.password.file=${ACTIVEMQ_CONF}/jmx.password"
> > >> ACTIVEMQ_SUNJMX_START="$ACTIVEMQ_SUNJMX_START
> > >>
> -Dcom.sun.management.jmxremote.access.file=${ACTIVEMQ_CONF}/jmx.access"
> > >> ACTIVEMQ_SUNJMX_START="$ACTIVEMQ_SUNJMX_START
> > >> -Dcom.sun.management.jmxremote.ssl=false"
> > >> ACTIVEMQ_SUNJMX_START="$ACTIVEMQ_SUNJMX_START
> > >> -Dcom.sun.management.jmxremote"
> > >>
> > >> Cheers,
> > >> Geurt
> > >>
> > >> -----Original Message-----
> > >> From: James Green [mailto:james.mk.green@gmail.com]
> > >> Sent: Friday, September 26, 2014 4:14 PM
> > >> To: users
> > >> Subject: 5.10.0: Unable to connect via jmx
> > >>
> > >> Config:
> > >>
> > >>         <managementContext>
> > >>             <managementContext connectorPort="11099"
> > rmiServerPort="11119"
> > >> jmxDomainName="org.apache.activemq"/>
> > >>         </managementContext>
> > >>
> > >>
> > >> Logs:
> > >>
> > >> 2014-09-26 14:58:31,278 | INFO  | JMX consoles can connect to
> > >> service:jmx:rmi://localhost:11119/jndi/rmi://localhost:11099/jmxrmi |
> > >> org.apache.activemq.broker.jmx.ManagementContext | JMX connector
> > >>
> > >> Replacing both localhost instances with dns name I can't connect via
> > >> jconsole (fails after about five seconds). I can telnet to both 11119
> > and
> > >> 11099.
> > >>
> > >> I'm trying every username/password pair I can find including nothing,
> > >> admin/admin, system/manager, admin/activemq
> > >>
> > >> Any ideas?
> > >>
> > >> Thanks,
> > >>
> > >> James
> > >>
> > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message