activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cfaini <cfa...@gmail.com>
Subject ActiveMQ-cpp causes segmentation faults on GCC 4.5.2
Date Thu, 25 Sep 2014 18:52:38 GMT
Hey there. I have been starting to work with ActiveMQ-cpp. Originally it
worked perfectly for me in my tests. However, I recently had to change my
environment and compiler from Solaris 10 w/ gcc-4.3.2 to Solaris 11 w/
gcc-4.5.2. I was able to get the ActiveMQ-cpp libraries to compile just
fine, but as soon as I run the example code from the ActiveMQ-cpp website it
generates a segmentation fault as soon as the threads try to join.

The code that I am trying to run is located here:
http://activemq.apache.org/cms/example.html. It ran just fine when I was
using an older version of GCC.

I get the following output from my code:
=======================================
Starting the example:
----------------------------------------------------------------------
HelloWorldConsumer::run
HelloWorldProducer::run
Sent message #1 from thread -4196748
Segmentation Fault (core dumped)

Are there any known issues/fixes for Active MQ with my version of GCC? I am
using what is currently the latest version of ActiveMQ-cpp: 3.8.3



--
View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-cpp-causes-segmentation-faults-on-GCC-4-5-2-tp4685881.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message