activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pfconrey <peter.con...@hilton.com>
Subject New ActiveMQ Installation Runs Out Of Memory After 30 Minutes
Date Thu, 21 Aug 2014 18:44:14 GMT
We have a fresh installation of ActiveMQ 5.9.1 running on Red Hat Linux. With
no outside connections, no queues, and only the default topic on the system,
the process runs out of memory (1GB allocated at startup with "-Xms1G
-Xmx1G") after about 30 minutes, even with absolutely no activity. I
initially ran into this problem with version 5.10.0, and downgraded to 5.9.1
to see if maybe it was something introduced in the new build.Literally, all
I did was:
    tar xzf apache-activemq-5.9.1-bin.tar.gz    mv apache-activemq-5.9.1-bin
activemq    cd activemq    bin/activemq start
Using "top", I noted that it started with about 150MB of real memory used,
and it continued to creep upward. Once top showed it with 1.1GB, there were
several heapdump, core, javacore and trace files in the base directory. The
javacore files all state:
    Dump Event "systhrow" (00040000) Detail "java/lang/OutOfMemoryError"
"Java heap space" received
Has anyone else encountered this? How did you fix it?



--
View this message in context: http://activemq.2283324.n4.nabble.com/New-ActiveMQ-Installation-Runs-Out-Of-Memory-After-30-Minutes-tp4684890.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message