activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kevin2014 <upennlist2...@gmail.com>
Subject activeMQ levelDB master/slave cluster
Date Wed, 13 Aug 2014 19:33:00 GMT
Hello, I am using activeMQ master/slave cluster  with levelDB  replicated by
zookeeper.
 with the following output from console: 


PSHOT\bin\win32>activemq.bat
wrapper  | --> Wrapper Started as Console
wrapper  | Launching a JVM...
jvm 1    | Wrapper (Version 3.2.3) http://wrapper.tanukisoftware.org
jvm 1    |   Copyright 1999-2006 Tanuki Software, Inc.  All Rights Reserved.
jvm 1    |
jvm 1    | Java Runtime: Oracle Corporation 1.7.0_67 C:\Program Files
(x86)\Java
\jre7
jvm 1    |   Heap sizes: current=15872k  free=12305k  max=1013632k
jvm 1    |     JVM args: -Dactivemq.home=../.. -Dactivemq.base=../..
-Djavax.net
.ssl.keyStorePassword=password -Djavax.net.ssl.trustStorePassword=password
-Djav
ax.net.ssl.keyStore=../../conf/broker.ks
-Djavax.net.ssl.trustStore=../../conf/b
roker.ts -Dcom.sun.management.jmxremote
-Dorg.apache.activemq.UseDedicatedTaskRu
nner=true -Djava.util.logging.config.file=logging.properties
-Dactivemq.conf=../
../conf -Dactivemq.data=../../data
-Djava.security.auth.login.config=../../conf/
login.config -Xmx1024m -Djava.library.path=../../bin/win32
-Dwrapper.key=7JJvTVF
5VnXQi50z -Dwrapper.port=32000 -Dwrapper.jvm.port.min=31000
-Dwrapper.jvm.port.m
ax=31999 -Dwrapper.pid=6236 -Dwrapper.version=3.2.3
-Dwrapper.native_library=wra
pper -Dwrapper.cpu.timeout=10 -Dwrapper.jvmid=1
jvm 1    | Extensions classpath:
jvm 1    |  
[..\..\lib,..\..\lib\camel,..\..\lib\optional,..\..\lib\web,..\..\l
ib\extra]
jvm 1    | ACTIVEMQ_HOME: ..\..
jvm 1    | ACTIVEMQ_BASE: ..\..
jvm 1    | ACTIVEMQ_CONF: ..\..\conf
jvm 1    | ACTIVEMQ_DATA: ..\..\data
jvm 1    | Loading message broker from: xbean:activemq.xml
jvm 1    |  INFO | Refreshing
org.apache.activemq.xbean.XBeanBrokerFactory$1@193
c227: startup date [Wed Aug 13 10:00:30 EDT 2014]; root of context hierarchy
jvm 1    |  INFO | Using Persistence Adapter: Replicated
LevelDB[C:\ActiveMQ\apa
che-activemq-5.11-20140808.003936-58-bin\apache-activemq-5.11-SNAPSHOT\bin\win32
\..\..\data\leveldb, bos:2181//activemq/leveldb-stores]
jvm 1    |  INFO | Starting StateChangeDispatcher
jvm 1    |  INFO | Client environment:zookeeper.version=3.4.5-1392090, built
on
09/30/2012 17:52 GMT
jvm 1    |  INFO | Client environment:host.name=WMT-VS002.Bos.local
jvm 1    |  INFO | Client environment:java.version=1.7.0_67
jvm 1    |  INFO | Client environment:java.vendor=Oracle Corporation
jvm 1    |  INFO | Client environment:java.home=C:\Program Files
(x86)\Java\jre7

jvm 1    |  INFO | Client
environment:java.class.path=../../bin/wrapper.jar;../.
./bin/activemq.jar
jvm 1    |  INFO | Client environment:java.library.path=../../bin/win32
jvm 1    |  INFO | Client
environment:java.io.tmpdir=C:\Users\george\AppData\Lo
cal\Temp\
jvm 1    |  INFO | Client environment:java.compiler=<NA>
jvm 1    |  INFO | Client environment:os.name=Windows 7
jvm 1    |  INFO | Client environment:os.arch=x86
jvm 1    |  INFO | Client environment:os.version=6.1
jvm 1    |  INFO | Client environment:user.name=george
jvm 1    |  INFO | Client environment:user.home=C:\Users\george
jvm 1    |  INFO | Client
environment:user.dir=C:\ActiveMQ\apache-activemq-5.11-
20140808.003936-58-bin\apache-activemq-5.11-SNAPSHOT\bin\win32
jvm 1    |  INFO | Initiating client connection,
connectString=bosvsvm01:2181
 sessionTimeout=2000
watcher=org.apache.activemq.leveldb.replicated.groups.ZKCli
ent@1fbdfd0
jvm 1    |  WARN | SASL configuration failed:
javax.security.auth.login.LoginExc
eption: No JAAS configuration section named 'Client' was found in specified
JAAS
 configuration file: '../../conf/login.config'. Will continue connection to
Zook
eeper server without SASL authentication, if Zookeeper server allows it.
jvm 1    |  INFO | Opening socket connection to server
brlvsvolap01.bluecrest.lo
cal/10.42.0.109:2181
jvm 1    |  WARN | unprocessed event state: AuthFailed
jvm 1    |  INFO | Socket connection established to bosvsvm01:2181.bos.local
/10.42.0.109:2181, initiating session
jvm 1    |  INFO | Session establishment complete on server
bosvsvm01:2181.bos.local/10.42.0.109:2181, sessionid = 0x4474d0f01983ec1,
negotiated timeout = 4
000




I used to have the same "warning" of "Client not found in specified JAAS
configuration",  but after that, it showed  "not enough cluster memebers
connected to elect a master",  and after I started another broker from
another machine using the same  zookeeper,  it can promote to master, and
new machines to be slave.  and I can see "web management available at ...", 
then the whole cluster works fine, even with the warning.

But now I get the output as I posted above,  didn't see the "not enough
cluster memebers to elect a master",  and after I started another node,  the
web management page is not available...
I don't remember what I changed in my configuration, but the cluster is not
working anymore.

Anyone has clue based my post above.

Thanks







--
View this message in context: http://activemq.2283324.n4.nabble.com/activeMQ-levelDB-master-slave-cluster-tp4684525.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message