activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: Lost messages - Abnormal Behaviour of activeMQ
Date Mon, 14 Jul 2014 16:26:48 GMT
On 07/14/2014 09:39 AM, Uttara wrote:
> Hi,
> I have been working on a project,where in activeMQ is our main messaging
> bus. We have  developed our product to be multitenent app,wherein we support
> many customers.
>
> Now that we use ActiveMQ,we found that messages are being lost without any
> behaviors in only two queues . There are three customers for which we create
> three connection object and using which we create three receivers, now at
> times except for the intended customer , the other two customer`s receiver
> are reading it but not ACKNOWLEDGING the message ,then that particular
> message is  lost and not found in the broker. it is being dequeued with out
> ACKNOWLEDGING it as we have client acknowledge as acknowledgement mode.
> Thanks in advance.
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Lost-messages-Abnormal-Behaviour-of-activeMQ-tp4683240.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
Be careful with client Ack, it acknowledges all received messages for 
the Session so far which can be confusing if you don't know it's 
happening.  For more help try to provide some more concrete info or a 
code sample.

-- 
Tim Bish
Sr Software Engineer | RedHat Inc.
tim.bish@redhat.com | www.fusesource.com | www.redhat.com
skype: tabish121 | twitter: @tabish121
blog: http://timbish.blogspot.com/


Mime
View raw message