activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tcarlyle <tcarl...@gmail.com>
Subject cant build activemq5.8.0 in linux (Ubuntu)
Date Thu, 10 Jul 2014 08:15:54 GMT
Hi all,
I have the situation here that I can build the activemq5.8.0 in windows
without a problem, but I cant on ubuntu.

My windows maven environment is:
Apache Maven 3.0.4 (r1232337; 2012-01-17 09:44:56+0100)
Maven home: C:\dev\apache-maven-3.0.4\bin\..
Java version: 1.6.0_33, vendor: Sun Microsystems Inc.
Java home: C:\Program Files\Java\jdk1.6.0_33\jre
Default locale: en_US, platform encoding: Cp1252

While my ubuntu one is:
Apache Maven 3.0.4
Maven home: /usr/share/maven
Java version: 1.6.0_45, vendor: Sun Microsystems Inc.
Java home: /usr/lib/jvm/java-6-oracle/jre
Default locale: en_US, platform encoding: ANSI_X3.4-1968
OS name: "linux", version: "3.11.0-12-generic", arch: "amd64", family:
"unix"

The Ubuntu build stops in the AMQ Store build, where I get a long list of
errors (see below) related with the kahadaptor being deprecated and the
package "org.apache.activemq.kaha.impl.data" not existing.

Any idea of what could be the cause of the error?

[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/store/kahadaptor/KahaTransactionStore.java:[54,18]
[deprecation] org.apache.activemq.store.kahadaptor.KahaPersistenceAdapter in
org.apache.activemq.store.kahadaptor has been deprecated
[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/store/kahadaptor/KahaTransactionStore.java:[58,25]
[deprecation] org.apache.activemq.store.kahadaptor.KahaPersistenceAdapter in
org.apache.activemq.store.kahadaptor has been deprecated
[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/kaha/impl/DataManager.java:[23,41]
package org.apache.activemq.kaha.impl.data does not exist
[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/kaha/impl/index/IndexItem.java:[25,41]
package org.apache.activemq.kaha.impl.data does not exist
[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/kaha/impl/index/IndexItem.java:[26,41]
package org.apache.activemq.kaha.impl.data does not exist
[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/kaha/impl/index/IndexItem.java:[33,34]
cannot find symbol
symbol: class Item
public class IndexItem implements Item, StoreEntry {
[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/kaha/impl/DataManager.java:[37,26]
cannot find symbol
symbol  : class RedoListener
location: interface org.apache.activemq.kaha.impl.DataManager
[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/store/amq/AMQMessageStore.java:[64,20]
[deprecation] org.apache.activemq.store.amq.AMQPersistenceAdapter in
org.apache.activemq.store.amq has been deprecated
[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/store/amq/AMQMessageStore.java:[81,27]
[deprecation] org.apache.activemq.store.amq.AMQPersistenceAdapter in
org.apache.activemq.store.amq has been deprecated
[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/store/kahadaptor/KahaReferenceStoreAdapter.java:[54,47]
[deprecation] org.apache.activemq.store.kahadaptor.KahaPersistenceAdapter in
org.apache.activemq.store.kahadaptor has been deprecated

[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/store/amq/AMQTransactionStore.java:[42,18]
[deprecation] org.apache.activemq.store.amq.AMQPersistenceAdapter in
org.apache.activemq.store.amq has been deprecated
[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/store/amq/AMQTransactionStore.java:[45,31]
[deprecation] org.apache.activemq.store.amq.AMQPersistenceAdapter in
org.apache.activemq.store.amq has been deprecated
[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/store/amq/AMQTopicMessageStore.java:[50,32]
[deprecation] org.apache.activemq.store.amq.AMQPersistenceAdapter in
org.apache.activemq.store.amq has been deprecated
[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/store/amq/AMQTxOperation.java:[97,26]
[deprecation] org.apache.activemq.store.amq.AMQPersistenceAdapter in
org.apache.activemq.store.amq has been deprecated
[ERROR]
/opt/activemqsrc/activemq-broker/activemq-amq-store/src/main/java/org/apache/activemq/kaha/impl/async/DataManagerFacade.java:[23,41]
package org.apache.activemq.kaha.impl.data does not exist




--
View this message in context: http://activemq.2283324.n4.nabble.com/cant-build-activemq5-8-0-in-linux-Ubuntu-tp4683056.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message