activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "manuele.simi" <manuele.s...@campagnelab.org>
Subject Accessing a BytesMessage multiple times wipes the payload
Date Fri, 27 Jun 2014 14:23:23 GMT
Hi all,

I have a  Topic in ActiveMQ where I publish BytesMessage using
javax.jms.TopicPublisher implementation provided by Qpid JMS Client.
Accessing the message from a consumer A (again, a javax.jms.TopicConsumer
implementation from Qpid) the first time returns the correct data. And the
same happens for all the next messages in the Topic. But, from that moment
on, accessing any message in the Topic a second time from A, or another
consumer B, the payload will return an empty byte array which has the length
of the data but all bytes are zero. All the properties and information
around the payload are correct. I know this happens if one reads the same
message twice without invoking reset(), but this is not the case. 

The strange thing is that if I restart ActiveMQ (persistence is enabled),
then I can read again the content of the message from a consumer once, then
the same behavior described occurs (i.e. no other consumer can access any
message's payload in the Topic). I'm a bit puzzled about this. It looks like
ActiveMQ itself does not reset a BytesMessage…. but is that possible?

With exactly the same code, I have no problem to send and receive
TextMessages and ObjectMessages multiple times. 

Any help would be really appreciated.

many thanks,
manuele



--
View this message in context: http://activemq.2283324.n4.nabble.com/Accessing-a-BytesMessage-multiple-times-wipes-the-payload-tp4682573.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message