activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From RobR <rob.richard...@rad-con.com>
Subject Problems installing and running examples on Windows 7
Date Mon, 23 Jun 2014 19:03:56 GMT
I am new both to Java and to ActiveMQ.  I have successfully installed
ActiveMQ, but I have not been able to get the examples to work.

At first, I tried the C# examples.  The examples would not build because I
do not have the DLL containing the Apache.NMS namespace.  I found and
downloaded a DLL named Apache.NMS.dll, but when I open the Add Reference
dialog box and select the Browse tab, browse to that file, and select it,
Visual Studio seems to accept it but the reference still has the little
exclamation mark inside it and the Path property for the reference remains
empty.  What file should I be using, and where do I get it?

Then I tried the Python stomppy example, since I will probably be using
Python in the final product.  I downloaded and installed the stomp module
(at least, I think I did it correctly), but neither publisher.py nor
listener.py would run.  In publisher.py, I got the following:
>>> Unhandled exception while debugging...
Traceback (most recent call last):
  File "C:\ActiveMQ\examples\stomp\python\stomppy\publisher.py", line 39, in
<module>
    conn.send(data, destination=destination, persistent='false')
TypeError: send() got multiple values for keyword argument 'destination'

When I tried listener.py, I got this:
>>> Unhandled exception while debugging...
Traceback (most recent call last):
  File "C:\ActiveMQ\examples\stomp\python\stomppy\listener.py", line 61, in
<module>
    conn.subscribe(destination=destination, ack='auto')
TypeError: subscribe() takes at least 3 arguments (3 given)

Can someone please straighten me out?

Thanks very much.

RobR



--
View this message in context: http://activemq.2283324.n4.nabble.com/Problems-installing-and-running-examples-on-Windows-7-tp4682400.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message