activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mtruchado <marcos.truch...@gmail.com>
Subject activemq-client does not close properly connections to the broker
Date Fri, 09 May 2014 08:25:54 GMT
Hi

This is my configuration:

client: JBoss using ActiveMQ resource adapter, which uses activemq-client
5.8.0
broker: ActiveMQ 5.8.0

The connection string is a failover between two different brokers, using
openwire

each openwire connection string is using the default configuration, this is,
the maxInactivityDuration is set by default by 30 seconds

What happen is that looks like the activemq-client fails to close properly
the connections every time that a connection have to be renew:

Setting the ActiveMQ log to DEBUG for activemq client I got the
re-connection call:

*2014-05-08T17:12:54.960* CEST DEBUG
[org.apache.activemq.transport.failover.FailoverTransport] (JCA PoolFiller)
Started unconnected
*2014-05-08T17:12:54.960* CEST DEBUG
[org.apache.activemq.transport.failover.FailoverTransport] (JCA PoolFiller)
Waking up reconnect task

Exactly at the same point when the Broker throws this warning:

*2014-05-08 17:12:54,960* | WARN  | 1.77:56728@12270 | Transport                       
| ivemq.broker.TransportConnection  238 | 104 -
org.apache.activemq.activemq-osgi - 5.8.0.redhat-60024 | Transport
Connection to: tcp://172.16.151.77:56728 failed: java.io.EOFException

Looks like the client fails to close the connection properly. Is this a
known issue?, I was looking into the ActiveMQ forum and I couldn't find
anything, the most similar post is this one:

http://activemq.2283324.n4.nabble.com/large-number-of-connections-from-the-same-client-td4675871.html

Basically I find this hint quite interesting:

/Inactive connections from the client (especially sockets in CLOSED_WAIT
state) indicate either the client or server failed to close the socket
properly.  There's a known issue with the same using SSL in java 1.6 (I
think it's fixed in 1.7)./

Because I think that It is what It is happening on my scenario, although I'm
using Java 7.



--
View this message in context: http://activemq.2283324.n4.nabble.com/activemq-client-does-not-close-properly-connections-to-the-broker-tp4681005.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message