activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: org.apache.activemq.broker.region.Queue.doBrowse never returns
Date Thu, 24 Apr 2014 15:44:08 GMT
hmm. that is the result of the fix for
https://issues.apache.org/jira/browse/AMQ-4930

the intent is to limit a browse or expire check to available memory or
max browse size.
I think the fix is in 5.9.1

As a workaround, disable periodic expiry checking.
policyEntry expireMessagesPeriod=0 and or configure a very small
maxBrowsePageSize and maxExpirePageSize

On 24 April 2014 16:21, matteor <matteo.rulli@abodata.com> wrote:
> Version: AMQ 5.9.0
>
> I'm dealing with a strange behavior of
> org.apache.activemq.broker.region.Queue.expireMessages() of
> org.apache.activemq.broker.region.Queue.expireMessagesTask. Basically this
> task stops working after few minutes after broker bootup.
> I tried to track down the source of the problem and I found out that the
> doBrowse method remains forever in the following while loop:
>
> I find this while quite strange. Besides, I checked in the doBrowse method
> in v. 5.8.0 and there is no trace of this while loop.
>
> Any hints on this?
>
> Thanks!
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/org-apache-activemq-broker-region-Queue-doBrowse-never-returns-tp4680530.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.



-- 
http://redhat.com
http://blog.garytully.com

Mime
View raw message