activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From karcel <klasmar...@gmail.com>
Subject Unable to connect when trying to use mqtt
Date Mon, 28 Apr 2014 21:34:09 GMT
Hi!

I am quite new in here and i got problem connecting to localhost while using
mqtt.

With usingn defaults:

     private static String url = ActiveMQConnection.DEFAULT_BROKER_URL;

        ConnectionFactory connectionFactory =new
ActiveMQConnectionFactory(url);
        Connection connection = connectionFactory.createConnection();
        connection.start();

I assume, it is using AMQP protocol as defaults. Now i would like to use
mqtt.
Since I am using activemq v5.9.1. there should be possibility to do so.

I tried this:

           private static String uri = "failover://mqtt://primary:1883";

        ConnectionFactory connectionFactory = new
ActiveMQConnectionFactory(uri);
        Connection connection = connectionFactory.createConnection();
        connection.start();

In xml file i have: <transportConnector name="mqtt"
uri="mqtt://0.0.0.0:1883?maximumConnections=1000&wireFormat.maxFrameSize=104857600"/>

Always is comes with errors:

Exception in thread "main" java.lang.NoClassDefFoundError:
org/fusesource/mqtt/codec/PINGRESP
	at
org.apache.activemq.transport.mqtt.MQTTProtocolConverter.<clinit>(MQTTProtocolConverter.java:87)
	at
org.apache.activemq.transport.mqtt.MQTTTransportFilter.<init>(MQTTTransportFilter.java:55)
	at
org.apache.activemq.transport.mqtt.MQTTTransportFactory.compositeConfigure(MQTTTransportFactory.java:57)
	at
org.apache.activemq.transport.TransportFactory.configure(TransportFactory.java:224)
	at
org.apache.activemq.transport.TransportFactory.doConnect(TransportFactory.java:120)
	at
org.apache.activemq.transport.TransportFactory.connect(TransportFactory.java:64)
	at
org.apache.activemq.ActiveMQConnectionFactory.createTransport(ActiveMQConnectionFactory.java:315)
	at
org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:330)
	at
org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:303)
	at
org.apache.activemq.ActiveMQConnectionFactory.createConnection(ActiveMQConnectionFactory.java:243)
	at BenchMQTT.Test_A_1.main(Test_A_1.java:35)
Caused by: java.lang.ClassNotFoundException:
org.fusesource.mqtt.codec.PINGRESP
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
	... 11 more

Any help?



--
View this message in context: http://activemq.2283324.n4.nabble.com/Unable-to-connect-when-trying-to-use-mqtt-tp4680645.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message