activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: ActiveMQ consumers stop accepting messages
Date Thu, 13 Mar 2014 10:20:44 GMT
Looks like consumers don't ack. What is the client side ack mode?
On 12 Mar 2014 23:11, "davery" <d_avery@audiblemagic.com> wrote:

> Hi,
>
> I have two ActiveMQ 5.8 instances setup in a network of brokers. Each
> instance is hosted on a separate machine running Ubuntu 12.04 with 8GB of
> memory. After one week in production, we started seeing consumers that
> wouldn't accept messages. In the web console I can see the messages enqueue
> and messages in the dispatch queue, but the messages are never consumed in
> the server application. Restarting the consumer doesn't fix the problem.
> When I tried restarting the ActiveMQ instance it failed to shutdown --
> needed to kill -9 the pid.
>
> I believe the problem is on the broker or in the CMS library, but I can't
> seem to track it down. Has anyone seen a problem like this before?
>
> ===================================================================
> Application topology, request/response pattern w/temp queues, not
> persistent:
>
> ASP.NET/NMS  <-- producer (x350) --> ActiveMQ 5.8 (x2) <-- consumer (x120)
> --> C++/CMS
> Win2003/IIS6                              Ubuntu 12.04/OpenJDK 7
> Ubuntu 12.04
>
> ===================================================================
> Portions of activemq.xml:
>
>         <amq:policyEntry queue=">"
>                 optimizedDispatch="true"
>                 lazyDispatch="false"
>                 producerFlowControl="false"
>                 strictOrderDispatch="false">
>                 <amq:deadLetterStrategy>
>                                 <amq:individualDeadLetterStrategy
> queuePrefix="DLQ."
> useQueueForQueueMessages="true" />
>                 </amq:deadLetterStrategy>
>                 <amq:dispatchPolicy>
>                         <amq:roundRobinDispatchPolicy />
>                 </amq:dispatchPolicy>
>                 <amq:messageGroupMapFactory>
>                         <amq:simpleMessageGroupMapFactory />
>                 </amq:messageGroupMapFactory>
>                 <amq:pendingQueuePolicy>
>                         <amq:vmQueueCursor />
>                 </amq:pendingQueuePolicy>
>         </amq:policyEntry>
>
>         <amq:memoryUsage>
>                 <amq:memoryUsage limit="64 mb"/>
>         </amq:memoryUsage>
>         <amq:storeUsage>
>                 <amq:storeUsage limit="100 gb"/>
>         </amq:storeUsage>
>         <amq:tempUsage>
>                 <amq:tempUsage limit="50 gb"/>
>         </amq:tempUsage>
>
> ===================================================================
> JVM memory:
>         ACTIVEMQ_OPTS_MEMORY="-Xms4G -Xmx4G"
>
> Thanks,
>
> Dave
>
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/ActiveMQ-consumers-stop-accepting-messages-tp4678923.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message