activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Geer <ch...@cxtsoftware.com>
Subject XA Transaction Warning using LevelDB
Date Sat, 08 Mar 2014 17:40:55 GMT
We just upgraded from AMQ 5.6 to AMQ 5.9 and also switch from Kahadb to
LevelDB. We haven't changed any of our code dealing with AMQ but now we are
getting warning log messages on every message we send using an XA
transaction (see below). The messages seem to be making it through so I'm
not sure what the warning really means. Is there some additional
configuration we need to do with LevelDB that wasn't required before?

10:27:41,638 | WARN  | m://default#43-1 | LevelDBStore
| 133 - org.apache.activemq.activemq-osgi - 5.9.0 | on prepare, the
transaction
XID:[1197822575,globalId=ffffffb235ffffffbaffffffa2441006f72672e6170616368652e61726965732e7472616e73616374696f6e0000000000000000000000000000,branchId=20007833ffffffbaffffffa2441006170616368652e61726965732e7472616e73616374696f6e0000000000000000000000000000]
does not exist

This is running on Karaf 2.3.4 along with Camel 2.12.3.

Thanks, Chris

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message