activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Li Li <fancye...@gmail.com>
Subject build active cms problems
Date Mon, 10 Mar 2014 10:35:11 GMT
my environment:
1. lsb_release -a
LSB Version:
:core-3.1-amd64:core-3.1-ia32:core-3.1-noarch:graphics-3.1-amd64:graphics-3.1-ia32:graphics-3.1-noarch
Distributor ID: RedHatEnterpriseServer
Description:    Red Hat Enterprise Linux Server release 5.5 (Tikanga)
Release:        5.5
Codename:       Tikanga

2. gcc --version
gcc (GCC) 4.1.2 20080704 (Red Hat 4.1.2-54)

3. autoconf --version
autoconf (GNU Autoconf) 2.59

build steps
1. build e2fsprogs-1.42.9
    1.1 ./configure
    1.2 make
    1.3 sudo make install
2. build cppunit-1.12.1
    the same as above
3. build apr-1.5.0
    the same as above
4. build apr-util-1.5.3
    4.1 ./configure --with-apr=/usr/local/apr/
    4.2 make
    4.3 sudo make install
5. build apr-iconv 1.2.1
    the same as above
6. build activemq-cpp-library-3.8.2
./autogen.sh
configure.ac:18: error: Autoconf version 2.61 or higher is required
configure.ac:18: the top level
autom4te: /usr/bin/m4 failed with exit status: 63
aclocal: autom4te failed with exit status: 63
autoreconf: aclocal failed with exit status: 63
7. ./configure
checking for APR... yes
checking APR version... 1.2.7
wanted regexes are 1\.[3-9]\.[0-9] 1\.[3-9]\.1[0-9]
configure: error: invalid apr version found, check the README for
supported versions.

I have installed apr-1.5, why it find 1.2.7?

Mime
View raw message