activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Li Li <fancye...@gmail.com>
Subject Re: build active cms problems
Date Tue, 11 Mar 2014 01:24:44 GMT
by using ./configure --with-openssl=/usr/local/ssl --with-apr=/usr/local/apr/
I have successfully make it.
thanks.

On Tue, Mar 11, 2014 at 8:57 AM, Li Li <fancyerii@gmail.com> wrote:
> openssl version
> OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008
> I am not a expert of linux, so how do I "remove" old version and
> install new version?
>
> On Mon, Mar 10, 2014 at 9:34 PM, Timothy Bish <tabish121@gmail.com> wrote:
>> On 03/10/2014 07:41 AM, Li Li wrote:
>>>
>>> 7. after I use ./configure --with-apr=/usr/local/apr, it's correct
>>> but after long time of make, there is error.(I have installed openssl
>>> 1.0 but still the same error)
>>>
>>> libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I../.. -ansi -pedantic
>>> -DLINUX -D_REENTRANT -D_GNU_SOURCE -I/usr/local/apr/include/apr-1
>>> -I/usr/kerberos/include -W -Wall -Wextra -Wconversion -fPIC
>>> -fstrict-aliasing -Wstrict-aliasing=2 -Wno-long-long -g -O2 -pthread
>>> -MT decaf/internal/net/ssl/openssl/libactivemq_cpp_la-OpenSSLSocket.lo
>>> -MD -MP -MF
>>> decaf/internal/net/ssl/openssl/.deps/libactivemq_cpp_la-OpenSSLSocket.Tpo
>>> -c decaf/internal/net/ssl/openssl/OpenSSLSocket.cpp  -fPIC -DPIC -o
>>> decaf/internal/net/ssl/openssl/.libs/libactivemq_cpp_la-OpenSSLSocket.o
>>> decaf/internal/net/ssl/openssl/OpenSSLSocket.cpp: In member function
>>> 'virtual void
>>> decaf::internal::net::ssl::openssl::OpenSSLSocket::startHandshake()':
>>> decaf/internal/net/ssl/openssl/OpenSSLSocket.cpp:367: error:
>>> 'SSL_set_tlsext_host_name' was not declared in this scope
>>> make[2]: ***
>>> [decaf/internal/net/ssl/openssl/libactivemq_cpp_la-OpenSSLSocket.lo]
>>> 错误 1
>>> make[2]: Leaving directory
>>> `/home/lili/activemqcpp/activemq-cpp-library-3.8.2/src/main'
>>> make[1]: *** [all-recursive] 错误 1
>>> make[1]: Leaving directory
>>> `/home/lili/activemqcpp/activemq-cpp-library-3.8.2'
>>> make: *** [all] 错误 2
>>>
>>> On Mon, Mar 10, 2014 at 6:35 PM, Li Li <fancyerii@gmail.com> wrote:
>>>>
>>>> my environment:
>>>> 1. lsb_release -a
>>>> LSB Version:
>>>>
>>>> :core-3.1-amd64:core-3.1-ia32:core-3.1-noarch:graphics-3.1-amd64:graphics-3.1-ia32:graphics-3.1-noarch
>>>> Distributor ID: RedHatEnterpriseServer
>>>> Description:    Red Hat Enterprise Linux Server release 5.5 (Tikanga)
>>>> Release:        5.5
>>>> Codename:       Tikanga
>>>>
>>>> 2. gcc --version
>>>> gcc (GCC) 4.1.2 20080704 (Red Hat 4.1.2-54)
>>>>
>>>> 3. autoconf --version
>>>> autoconf (GNU Autoconf) 2.59
>>>>
>>>> build steps
>>>> 1. build e2fsprogs-1.42.9
>>>>      1.1 ./configure
>>>>      1.2 make
>>>>      1.3 sudo make install
>>>> 2. build cppunit-1.12.1
>>>>      the same as above
>>>> 3. build apr-1.5.0
>>>>      the same as above
>>>> 4. build apr-util-1.5.3
>>>>      4.1 ./configure --with-apr=/usr/local/apr/
>>>>      4.2 make
>>>>      4.3 sudo make install
>>>> 5. build apr-iconv 1.2.1
>>>>      the same as above
>>>> 6. build activemq-cpp-library-3.8.2
>>>> ./autogen.sh
>>>> configure.ac:18: error: Autoconf version 2.61 or higher is required
>>>> configure.ac:18: the top level
>>>> autom4te: /usr/bin/m4 failed with exit status: 63
>>>> aclocal: autom4te failed with exit status: 63
>>>> autoreconf: aclocal failed with exit status: 63
>>>> 7. ./configure
>>>> checking for APR... yes
>>>> checking APR version... 1.2.7
>>>> wanted regexes are 1\.[3-9]\.[0-9] 1\.[3-9]\.1[0-9]
>>>> configure: error: invalid apr version found, check the README for
>>>> supported versions.
>>>>
>>>> I have installed apr-1.5, why it find 1.2.7?
>>
>>
>> Your system has some older versions installed in the primary location which
>> is causing troubles.  Most likely you have a old OpenSSL 0.9.7 or earlier
>>
>> --
>> Tim Bish
>> Sr Software Engineer | RedHat Inc.
>> tim.bish@redhat.com | www.fusesource.com | www.redhat.com
>> skype: tabish121 | twitter: @tabish121
>> blog: http://timbish.blogspot.com/
>>

Mime
View raw message