activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Netlancer <netlan...@mobigraph.co>
Subject Message forwarding on two brokers not working for MQTT
Date Fri, 21 Mar 2014 03:16:29 GMT
Hi ,

I have setup two brokers A(sender) and B(receiver). both the brokers 
have been configured with transport connector for mqtt protocol. only 
broker A has been setup for network connector.AdvisorySupport is enabled.

I have 2 clients ( producer) connecting to broker A and consumer 
connecting to Broker B. The topic is hierarchical in nature ( c.d ) . 
since i am using mqtt protocol, both producer and consumer uses the 
topic format  ( c/d)

Scenario 1
when  broker A is configured with empty dynamicallyIncludedDestination, 
the consumer in broker B is able to get the message.

when broker A is configured with dynamicallyIncludedDestination as "c.*" 
or "c.>" , the consumer in broker B is not able to get any message. The 
message is never forwarded from broker A to B.

broker A configuration:
         <networkConnectors>
           <networkConnector name="brokerA" 
uri="static:(tcp://localhost:61617)" userName="brokerAusr">
             <dynamicallyIncludedDestinations>
                 <topic physicalName="C1/#"/> or  <topic 
physicalName="C1.*"/> or <topic physicalName="C1.> "/>
             </dynamicallyIncludedDestinations>
           </networkConnector>
         </networkConnectors>

I am using 5.10-SNAPSHOT.

Please, can you let me know if there is anything wrong in the way i have 
configured.

Thanks,
nl


Mime
View raw message