activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tobi <tobias.grossm...@q-perior.com>
Subject WebSocket in ActiveMQ 5.8.0 org.apache.activemq.transport.ws Missing Transport Sheme
Date Wed, 26 Mar 2014 08:39:49 GMT
Hi I'm searching the Transport scheme: [ws], Probably in class:
org.apache.activemq.transport.ws 
Without I'wont be able to start a broker with a web socket.  

I've added the following maven dependencies, but still no luck, and it seems
that activemq-optional is only available in 5.7.0 - maybe thats the reason?  

    <dependency>
      <groupId>org.apache.activemq</groupId>
      <artifactId>activemq-client</artifactId>
      <version>5.9.0</version>
    </dependency>
    <dependency>
      <groupId>org.apache.activemq</groupId>
      <artifactId>activemq-camel</artifactId>
      <version>5.9.0</version>
    </dependency>
    <dependency>
      <groupId>org.apache.activemq</groupId>
      <artifactId>activemq-pool</artifactId>
      <version>5.9.0</version>
    </dependency>
	<dependency>
		<groupId>org.apache.activemq</groupId>
		<artifactId>activemq-http</artifactId>
		<version>5.9.0</version>
		<scope>provided</scope>
	</dependency> 
	<dependency>
		<groupId>org.apache.activemq</groupId>
		<artifactId>activemq-web</artifactId>
		<version>5.9.0</version>
		<scope>provided</scope>
	</dependency>
	<dependency>
		<groupId>org.apache.activemq</groupId>
		<artifactId>activemq-stomp</artifactId>
		<version>5.9.0</version>
		<scope>provided</scope>
	</dependency> 	 	
	<dependency>
		<groupId>org.apache.activemq</groupId>
		<artifactId>activemq-optional</artifactId>
		<version>5.7.0</version>
		<scope>provided</scope>
	</dependency> 
    <dependency>
      <groupId>org.apache.activemq</groupId>
      <artifactId>activemq-mqtt</artifactId>
      <version>5.9.0</version>
    </dependency>    
	<dependency>
		<groupId>org.apache.activemq</groupId>
		<artifactId>activemq-all</artifactId>
		<version>5.9.0</version>
		<scope>provided</scope>
	</dependency>     
    <dependency>
      <groupId>org.apache.activemq</groupId>
      <artifactId>activemq-broker</artifactId>
      <version>5.9.0</version>
    </dependency>
    <dependency>
      <groupId>org.apache.activemq</groupId>
      <artifactId>activemq-spring</artifactId>
      <version>5.9.0</version>
    </dependency>

Regards, Tobi 



--
View this message in context: http://activemq.2283324.n4.nabble.com/WebSocket-in-ActiveMQ-5-8-0-org-apache-activemq-transport-ws-Missing-Transport-Sheme-tp4679527.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message