activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From divine <divine1...@gmail.com>
Subject Replicated LevelDB performance problem
Date Mon, 17 Mar 2014 09:16:22 GMT
I hava done some test while using the new feature  Replicated LevelDB.
I'm running a 3 node ActiveMQ quorum_mem and 3 node Zookeeper.
In a PtoP situation,using a pooled connectionFactory to send Messages with
one queue.
I observed 3000 msgs/sec which is similar with using levelDB or KahaDb in
normal situation.
However,the performance goes down to 100 msgs/sec while the queue is empty
and has consumers waiting for receiving.

It's really strange.This only occurs when the queue has consumers waiting
for receiving and the queue is empty.
And in my test the only one way to improve the throughput is to increase the
maxConnections in the pool.
It seems that the throughput of a connection is restricted while it's all ok
if i changed the persistAdapter to levelDB or kahaDb.
I doubt there is lock problems when dealing with sending and receiving at
the same time for replicated levelDB.

I'm very confused now.I wonder whether it's my configuration problem or it's
really a bug.
And i wonder which master-slave solution is maturer and recommended for
activemq in a industrial practice.



--
View this message in context: http://activemq.2283324.n4.nabble.com/Replicated-LevelDB-performance-problem-tp4679150.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message