activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John D. Ament" <john.d.am...@gmail.com>
Subject Re: Accessing the hawtio console
Date Mon, 03 Feb 2014 16:59:28 GMT
Hi,

I'm using ActiveMQ 5.9, which seems to come bundled with hawtio.

I'm able to disable the security constraint and access the old broker,
but not the hawtio console.

I do see this in the logs, which seems about right:

2014-02-03 11:58:06,273 | INFO  | Starting hawtio authentication
filter, JAAS realm: "activemq" authorized role: "admins" role
principal classes: "org.apache.activemq.jaas.GroupPrincipal" |
io.hawt.web.AuthenticationFilter | main

I'm assuming that the correct credentials are admin/admin right?

On Mon, Feb 3, 2014 at 4:55 AM, Dejan Bosanac <dejan@nighttale.net> wrote:
> Hi John,
>
> how are you starting your broker and what version are you using? Try
> setting some hawtio system properties like
>
> -Dhawtio.realm=activemq -Dhawtio.role=admins
> -Dhawtio.rolePrincipalClasses=org.apache.activemq.jaas.GroupPrincipal
> -Djava.security.auth.login.config=$ACTIVEMQ_CONF/login.config
>
> and see if that helps.
>
> Regards
> --
> Dejan Bosanac
> ----------------------
> Red Hat, Inc.
> FuseSource is now part of Red Hat
> dbosanac@redhat.com
> Twitter: @dejanb
> Blog: http://sensatic.net
> ActiveMQ in Action: http://www.manning.com/snyder/
>
>
> On Mon, Feb 3, 2014 at 8:48 AM, Claus Ibsen <claus.ibsen@gmail.com> wrote:
>
>> Hi
>>
>> Under the docs directory there is a web console readme file. It has
>> some pointers about setting up security.
>> If still a problem then try enabling DEBUG or TRACE logging at io.hawt
>> and see if you can see more details.
>>
>> On Sun, Feb 2, 2014 at 5:24 PM, John D. Ament <john.d.ament@gmail.com>
>> wrote:
>> > Hi all,
>> >
>> > If I'm using the standalone broker of activemq, I'm not able to log
>> > in.  From what I saw, admin/admin should be the right credentials, but
>> > no matter what I use to login I'm getting back a 403 forbidden.
>> >
>> > I have no made any configuration changes to the default app.
>> >
>> > John
>>
>>
>>
>> --
>> Claus Ibsen
>> -----------------
>> Red Hat, Inc.
>> Email: cibsen@redhat.com
>> Twitter: davsclaus
>> Blog: http://davsclaus.com
>> Author of Camel in Action: http://www.manning.com/ibsen
>> Make your Camel applications look hawt, try: http://hawt.io
>>

Mime
View raw message