activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: Accessing the hawtio console
Date Mon, 03 Feb 2014 09:55:11 GMT
Hi John,

how are you starting your broker and what version are you using? Try
setting some hawtio system properties like

-Dhawtio.realm=activemq -Dhawtio.role=admins
-Dhawtio.rolePrincipalClasses=org.apache.activemq.jaas.GroupPrincipal
-Djava.security.auth.login.config=$ACTIVEMQ_CONF/login.config

and see if that helps.

Regards
--
Dejan Bosanac
----------------------
Red Hat, Inc.
FuseSource is now part of Red Hat
dbosanac@redhat.com
Twitter: @dejanb
Blog: http://sensatic.net
ActiveMQ in Action: http://www.manning.com/snyder/


On Mon, Feb 3, 2014 at 8:48 AM, Claus Ibsen <claus.ibsen@gmail.com> wrote:

> Hi
>
> Under the docs directory there is a web console readme file. It has
> some pointers about setting up security.
> If still a problem then try enabling DEBUG or TRACE logging at io.hawt
> and see if you can see more details.
>
> On Sun, Feb 2, 2014 at 5:24 PM, John D. Ament <john.d.ament@gmail.com>
> wrote:
> > Hi all,
> >
> > If I'm using the standalone broker of activemq, I'm not able to log
> > in.  From what I saw, admin/admin should be the right credentials, but
> > no matter what I use to login I'm getting back a 403 forbidden.
> >
> > I have no made any configuration changes to the default app.
> >
> > John
>
>
>
> --
> Claus Ibsen
> -----------------
> Red Hat, Inc.
> Email: cibsen@redhat.com
> Twitter: davsclaus
> Blog: http://davsclaus.com
> Author of Camel in Action: http://www.manning.com/ibsen
> Make your Camel applications look hawt, try: http://hawt.io
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message