activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From yygcyupeng <402673...@qq.com>
Subject Duplex networkConnector can not reconnect when network is restored on ActiveMQ 5.9.
Date Thu, 20 Feb 2014 09:30:50 GMT
Hi All, 

We are attempting to use a duplex networkConnector  for sending message from
brokerA to brokerB.like this:
                       URI uri = new URI("static:(tcp://" + ip + ":"+ port +
")");
			nc = new DiscoveryNetworkConnector(uri); 
			nc.setDuplex(true);
			nc.setName(ncUniqueName);
			nc.setBrokerName("localBrokerName");
			nc.setDecreaseNetworkConsumerPriority(false);
			requestQueue = new EMQQueue("localBrokerName:"+name);
			EMQQueue responseQueue = new EMQQueue(name+":localBrokerName");
			nc.setStaticBridge(true);
			nc.addStaticallyIncludedDestination(requestQueue);
			nc.addStaticallyIncludedDestination(responseQueue);
			brokerService.addNetworkConnector(nc); 
			nc.start();

With in AtiveMQ 5.7,when network interupted are restored,brokerA will
reconnect brokerB,and messages still send.but now ,when we update to
activemq 5.9,messages cant send from brokerA to brokerB.
And why? Whats the difference between 5.7 and 5.9 on static network
connector?


Best regards, 
-John



--
View this message in context: http://activemq.2283324.n4.nabble.com/Duplex-networkConnector-can-not-reconnect-when-network-is-restored-on-ActiveMQ-5-9-tp4678187.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message