activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From abhi1301 <abhishek.sinh...@yahoo.in>
Subject java.lang.IllegalArgumentException: Invalid connect parameters: {wireFormat.maxInactivityDuration=-1}
Date Fri, 31 Jan 2014 13:04:30 GMT
I was using activemq-core-5.7.0 and everything was working fine. Then I tried
to upgrade to 5.8.0. I came to know that activemq-core is replaced by
activemq-client and activemq-broker. So I add both the jars
activemq-client-5.8.0 and activemq-broker-5.8.0 to my classpath. I also
added activemq-spring-5.8.0 and activemq-jaas-5.8.0.

My broker URL was
"tcp://localhost:61617?wireFormat.maxInactivityDuration=0". After upgrade I
got 

java.lang.IllegalArgumentException: Invalid connect parameters:
{wireFormat.maxInactivityDuration=-1}

If I simply use "tcp://localhost:61617" then everything is fine.

I also tried to add activemq-openwire-legacy-5.8.0.jar but no luck.

How to resolve this??



--
View this message in context: http://activemq.2283324.n4.nabble.com/java-lang-IllegalArgumentException-Invalid-connect-parameters-wireFormat-maxInactivityDuration-1-tp4677159.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message