activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From francesco <francesco.malve...@unimore.it>
Subject Hawtio send message User name [null] or password is invalid
Date Wed, 15 Jan 2014 08:28:02 GMT
My activemq-5.9.0 uses LDAPLogin in activemq.xml and both older /admin
console and newer /hawtio console are secured with LDAP.

When I publish a message, older /admin console uses the credentials in
./conf/credentials.properties in order to authenticate itself (everything
works).

Hawtio instead fails with a:
[ActiveMQ VMTransport: vm://localhost#9] [WARN] [2014-01-15 09:19:59,321]
o.a.a.b.TransportConnection: Failed to add Connection
ID:filch-36184-1389772907025-11:1
java.lang.SecurityException: User name [null] or password is invalid.
	at
org.apache.activemq.security.JaasAuthenticationBroker.addConnection(JaasAuthenticationBroker.java:80)
~[activemq-broker-5.9.0.jar:5.9.0]
[...]
	at javax.security.auth.login.LoginContext.invokePriv(LoginContext.java:695)
~[na:1.7.0_06]
	at javax.security.auth.login.LoginContext.login(LoginContext.java:594)
~[na:1.7.0_06]
	at
org.apache.activemq.security.JaasAuthenticationBroker.addConnection(JaasAuthenticationBroker.java:73)
~[activemq-broker-5.9.0.jar:5.9.0]
	... 11 common frames omitted
[ActiveMQ BrokerService[localhost] Task-10] [INFO] [2014-01-15 09:20:01,323]
o.a.a.b.TransportConnection: Stopping vm://localhost#8 because Failed with
SecurityException: User name [null] or password is invalid.

How can I instruct hawtio to authenticate when sending messages? BTW, why
activemq allows hawtio to browse destinations while forbidding it to post?

thank you for the clarifications!

Francesco



--
View this message in context: http://activemq.2283324.n4.nabble.com/Hawtio-send-message-User-name-null-or-password-is-invalid-tp4676293.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message