activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: ActiveMQ broker 5.9 doesn't close TCP connection if qpid client close amqp connection
Date Sun, 22 Dec 2013 18:19:55 GMT
On 12/20/2013 07:29 AM, soe wrote:
> Hi all,
>
> I've start a activemq broker, configured with amqp connector. On the other
> hand, I've a Qpid amqp client which send message to the broker. If I let the
> sender close the connection by himself (producer, session & connection), I
> see on hawtio admin interface that connection isn't fully close. The broker
> holds open the tcp connection.
>
> I've not found any information about these behavior in the hole net :-(
> Have anybody any idea what happens and what can I do, that the broker fully
> close the connection.
>
> I've also tried to set transport.connectionTimeout or soTime within the
> connector URI within broker configuration. But nothing helps.
>
> Thanks for help.
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-broker-5-9-doesn-t-close-TCP-connection-if-qpid-client-close-amqp-connection-tp4675756.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
First thing to try would be a 5.10-SNAPSHOT as we've fixed a bunch of 
stuff.  Also there's a 0.26-SNAPSHOT of the QPid JMS client that has 
many, many fixes.

-- 
Tim Bish
Sr Software Engineer | RedHat Inc.
tim.bish@redhat.com | www.fusesource.com | www.redhat.com
skype: tabish121 | twitter: @tabish121
blog: http://timbish.blogspot.com/


Mime
View raw message