activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: Segmentation fault after ActiveMQCPP::shutdownLibrary()
Date Tue, 03 Dec 2013 11:16:47 GMT
On 12/03/2013 02:57 AM, MillieretXavier wrote:
> I have a problem on CMS library. When I invoke the
> ActiveMQCPP::shutdownLibrary(), I have the following error:
> Segmentation fault
> decaf::lang::Exception::buildMessage (this=0x3570c8, format=0xab99fe35
> "Failed to Lock OS Mutex"
> .....
>
>
> in my code, I think I did the right things, like:
> if( connection != NULL )
>      {
>        connection->close();
>        delete connection;
>        connection = NULL;
>      }
>
> and after activemq::library::ActiveMQCPP::shutdownLibrary();
>
> I have not session open, just have one connection to the activemq.
>
> I used the cms 3.8.1 and my platform is centos 5.5 i386
>
> any help will be appreciate.
>
> Thank you very much
>
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Segmentation-fault-after-ActiveMQCPP-shutdownLibrary-tp4675017.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
 From the sounds of it you have some CMS object still alive at the time 
of the shutdown call, perhaps a connection factory or some such?

-- 
Tim Bish
Sr Software Engineer | RedHat Inc.
tim.bish@redhat.com | www.fusesource.com | www.redhat.com
skype: tabish121 | twitter: @tabish121
blog: http://timbish.blogspot.com/


Mime
View raw message