activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From javaG <zenma...@gmail.com>
Subject ActiveMQ fails to deliver message to Stomp consumer
Date Sun, 08 Dec 2013 22:22:44 GMT

I am using NodeJs stomp client to do messaging between stomp client and JMS
client. While Stomp producer successfully sends message to JMS consumer but
the reverse is not working. While JMS producer successfully sends the
message to the destination on which Stomp consumer is subscribed to, but
Stomp consumer never receives the message.  Looking at ActiveMQ web console
for queses all looks fine. Stomp consumer is registered and message is
enqued for this destination but nothing is dequeued from the this
destination.

The relevant ActiveMQ debug log is:

this shows that stomp consumer for q2 is registered by amq

2013-12-08 15:08:12,731 | DEBUG | amq-broker adding consumer:
ID:ov73uc05.opr.statefarm.org-34519-1386533132674-4:1:-1:1 for destination:
queue://q2 | org.apache.activemq.broker.region.AbstractRegion | ActiveMQ
Transport: tcp:///13.241.61.129:56651@61613


this shows that JMS producer sends the message to q2

2013-12-08 15:08:12,914 | DEBUG | amq-broker Message
ID:myhost-55685-1386522392871-7:1:1:2:4 sent to queue://q2 |
org.apache.activemq.broker.region.Queue | ActiveMQ Transport:
tcp:///13.6.8.143:54800@61616


Any one can help to find solution for this?

Thanks



--
View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-fails-to-deliver-message-to-Stomp-consumer-tp4675273.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message