activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From edbras <>
Subject Re: When will activemq-core 5.9 be present in maven central repo?
Date Thu, 05 Dec 2013 12:01:43 GMT
> I think activemq-broker and activemq-kahadb-store should be enough. 
If I do so, I do get the xml ns error below.

If I include the activemq-all, it works, but then I get other conflicting
issues like slf4j, geronimo, etc... 
Example usage: 
<amq:queue id="jmsQueueDeclarationSnd" 
physicalName="${jms.queue.declaration.snd}" />

BTW: I followed  LINKE <>   and
it still uses the activemq-core xsd as ref in 5.9.0.

I think the error occurs because of the missing
META_INF/services/spring.schemas which are present in the activemq-all.jar
but not in the jars I use. I searched a bit, but can't find them. I also
included activemq-client, but no luck so far...

So which jar's must I use that include the handlers (beside activemq-all).

- Ed

---- ERROR:
Caused by:
Configuration problem: Unable to locate Spring NamespaceHandler for XML
schema namespace []
Offending resource: class path resource [spring/jms-common-bv-core.xml]

---- XML config piece:
<beans xmlns=""

View this message in context:
Sent from the ActiveMQ - User mailing list archive at

View raw message