activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Posta <christian.po...@gmail.com>
Subject Re: WARN | Store update waiting on 1 replica(s) to catch up to log position 0
Date Thu, 07 Nov 2013 20:04:48 GMT
Would it be possible to try with a 5.10 snapshot? There were some
recent fixes around leveldb replication, and before trying to
reproduce on my side, would be good to know you see it in the latest:

https://repository.apache.org/content/repositories/snapshots/org/apache/activemq/apache-activemq/5.10-SNAPSHOT/

On Thu, Nov 7, 2013 at 5:27 AM, triumvir <peter.naber@alfa.de> wrote:
> Hi,
>
> I have installed a Replicated LevelDB Store with 3 zookeeper Server and 3
> activemq Server. It works well, but if I test it with jmeter and kill a
> activemq-master with kill -9 ( simulate power blackout ), often it works
> well but at two times following message was logged endless to the logfile of
> the slave which should become master ( controlled by the width variable in
> the activemq.xml ).
>
> *Store update waiting on 1 replica(s) to catch up to log position 0*
>
> At this time, no activemq Instance is started and the activemq-cluster
> doesn't work :-(
>
> After I start the killed activemq server, the cluster works well again and
> the slave become master.
>
>
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/WARN-Store-update-waiting-on-1-replica-s-to-catch-up-to-log-position-0-tp4674001.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.



-- 
Christian Posta
http://www.christianposta.com/blog
twitter: @christianposta

Mime
View raw message