activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jose MarĂ­a Zaragoza <demablo...@gmail.com>
Subject java.lang.NoClassDefFoundError: org/apache/activemq/util/IOExceptionSupport
Date Fri, 22 Nov 2013 09:58:31 GMT
Hi:

I'm using AMQ 5.8.0 , on client & server side.

Client side is a web application running on Tomcat 6 and its running ok
Connection transport is in failover mode

"failover:(tcp://broker1:61616?connectionTimeout=3000,tcp://broker2:61617?connectionTimeout=3000)?timeout=5000&startupMaxReconnectAttempts=1&maxReconnectAttempts=1&randomize=false&priorityBackup=false"


On server side, I've changed in broker's configuration file  (
activemq,xml ) the parameter updateClusterClients from "true"  to
"false" and I've restarted it
And from this moment , a lot of error messages are printed in Tomcat's
catalina.out


Information: Illega access: this web application instance was stopped
. Could not load META-INF/services/org/apache/activemq/transport/nio..
      Exception in thread "ActiveMQ Task-708852"
java.lang.NoClassDefFoundError:
org/apache/activemq/util/IOExceptionSupport
        at org.apache.activemq.transport.TransportFactory.findTransportFactory(TransportFactory.java:178)
        at org.apache.activemq.transport.TransportFactory.compositeConnect(TransportFactory.java:89)
        at org.apache.activemq.transport.failover.FailoverTransport.doReconnect(FailoverTransport.java:986)^C
        at org.apache.activemq.transport.failover.FailoverTransport$2.iterate(FailoverTransport.java:143)
        at org.apache.activemq.thread.PooledTaskRunner.runTask(PooledTaskRunner.java:129)
        at org.apache.activemq.thread.PooledTaskRunner$1.run(PooledTaskRunner.java:47)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:722)


How is it possible a "java.lang.NoClassDefFoundError:
org/apache/activemq/util/IOExceptionSupport" exception if I didn't
restart Tomcat server ?
Any ideas ?

Thanks and regards

Mime
View raw message