activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruce Pennypacker <bruce.pennypac...@gmail.com>
Subject Re: ActiveMQ + JMX + SSL + AWS
Date Tue, 19 Nov 2013 20:58:36 GMT
Thanks, Timothy.  I've been using the public IP like that but it hasn't
helped.  I actually just noticed the following exception that I missed
initially:

 Failed to start JMX connector Cannot bind to URL
[rmi://localhost:1199/jmxrmi]: javax.naming.NoPermissionException [Root
exception is java.rmi.ServerException: RemoteException occurred in server
thread; nested exception is:
        java.rmi.AccessException: Cannot modify this registry]. Will
restart management to re-create JMX connector, trying to remedy this issue.

I've tried setting connectorHost in the managementContext to both the FQDN
and the internal 10.* IP, and I've also tried different ports, but no
matter what I try I always see this exception a few seconds after I start
up ActiveMQ.  Any ideas on this one?

-Bruce


On Tue, Nov 19, 2013 at 3:26 PM, Timothy Creswick <
Timothy.Creswick@vorboss.com> wrote:

> Hi Bruce,
>
> I'm pretty sure the issue is going to be the line:
>
> -Djava.rmi.server.hostname=<public IP>
>
> I think if you change that to the actual host IP (i.e. the EC2 internal
> 10.* IP) it will work.
>
> Let me know how you get on.
>
> T
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message