activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Creswick <Timothy.Cresw...@vorboss.com>
Subject RE: ActiveMQ + JMX + SSL + AWS
Date Tue, 19 Nov 2013 22:46:48 GMT
> I've tried setting connectorHost in the managementContext to both the FQDN
> and the internal 10.* IP, and I've also tried different ports, but no
> matter what I try I always see this exception a few seconds after I start
> up ActiveMQ.  Any ideas on this one?

Yup in that case it's simple, you need to set a policy file.

Google search will reveal more: http://stackoverflow.com/questions/9939883/can-not-start-jstatd-in-linux

But it will look something like this:

grant codebase "file:${java.home} " {
   permission java.security.AllPermission;
};

(you'll need to set the path correctly)

The other issue might be that something else is using the port. Check with "netstat -apn"
to see what other processes are listening. You might have multiple JMX processes.

You definitely don't want your external IP in your configuration because the process won't
be able to bind to that address.

Can you run it with the 10.x IP and see if you get the same error?

T

Mime
View raw message