activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From francesco <francesco.malve...@unimore.it>
Subject Re: Endless Failed to log in, Forbidden with hawt.io
Date Tue, 05 Nov 2013 07:09:22 GMT
Il 04/11/2013 18:41, gmicky [via ActiveMQ] ha scritto:
> 
> 
> Hello Francesco,
> 
> I was struggling with this issue as well on my side it was due to using
> custom startup script which sets custom ACTIVEMQ_OPTS. 
> 
>  in apache-activemq-5.9.0/bin/activemq some variables are setup which are
> needed for hawkio to authenticate and those are only loaded if ACTIVEMQ_OPTS
> variable is not previously declared.
> 
> When you run activemq use ps ax and check that JVM used for activemq is not
> missing following parameters from apache-activemq-5.9.0/bin/activemq file:
> 
> ACTIVEMQ_OPTS="$ACTIVEMQ_OPTS $ACTIVEMQ_OPTS_MEMORY 
> -Djava.util.logging.config.file=logging.properties -Dhawtio.realm=activemq
> -Dhawtio.role=admins
> -Dhawtio.rolePrincipalClasses=org.apache.activemq.jaas.GroupPrincipal
> -Djava.security.auth.login.config=$ACTIVEMQ_CONF/login.config"
> 
> Without those authentication for hawio console will not work.


thank you so much!

In my setup also startup variables are messed up, so I think it has to
be as you are saying,

Again, thank you for your time,

Francesco





--
View this message in context: http://activemq.2283324.n4.nabble.com/Endless-Failed-to-log-in-Forbidden-with-hawt-io-tp4673183p4673885.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message